BioNumerics Tutorial:

Importing and processing gel images
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Aim

Comprehensive tools for the processing of electrophoresis fingerprints, both from slab gels and capillary
sequencers are incorporated into BioNumerics. In this tutorial we will focus on the import and processing
of gel images. Processing tools include lane finding, normalization of the patterns, band finding, etc.
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Sample data

As an exercise, we will import an 8-bit TIFF gel image which was generated by PFGE with the restriction
enzyme Xba-I.
The gel image can be downloaded from the Applied Maths website: Go to http://www.applied-maths.
com/download/sample-data and click on ”BioNumerics Tutorial Data”.
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Creating a fingerprint type experiment

First we need to create a new fingerprint type experiment before we can import a gel image file.
1. Create a new database (see tutorial ”Creating a new database”) or open an existing database.
2. In the Main window, click on

in the toolbar of the Experiment types panel and select Fingerprint type

from the list (see Figure 1).

Figure 1: The Create a new experiment type dialog box.

3. Press <OK>, enter a name, for example PFGE-XbaI and press <Next>.
4. In the next window, make sure that Two-dimensional TIFF files and 8-bit (256 gray values) are selected
and press <Next>.

5. In the next dialog box, select Yes for fingerprints with inverted densitometric values.
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6. Press <Next> to proceed.
7. In the final step, leave No selected for applying a background subtraction.
8. Press <Finish> to complete the creation of the new fingerprint type.
The Experiment types panel now lists the fingerprint type PFGE-XbaI (see Figure 2).

Figure 2: The Experiment types panel.

You can still change the resolution, inversion, and background subtraction settings later when
processing a gel.
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Importing a fingerprint gel file
1. To add a new fingerprint file to the database, select File > Import... (

, Ctrl+I) and select Import gel

file under Fingerprint type data (see Figure 3).

Figure 3: Import tree.

2. Press <Import> to call the Select fingerprint file dialog box.
3. Select the file ec-XbaI-001.tif in the BioNumerics Tutorial data \PFGE TIFFS folder.
The dialog also asks if you want to edit the image by opening the image editor. Uncheck the Open in image
editor option if you are sure the file is an uncompressed gray scale TIFF image. For the conversion to an
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Figure 4: Select gel image.

uncompressed gray scale TIFF file make sure the option is checked.
4. Since the example file is an uncompressed gray scale TIFF file, uncheck the option and press <OK>.
The gel image is now available in the Fingerprint files panel (see Figure 5). The file is marked with a red
”N” ( ) indicating that the image has not been processed yet.

Figure 5: The Experiment types panel and Fingerprint files panel.
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Processing a fingerprint gel file

5.1

Introduction

Before linking our fingerprint lanes to entries in our database, we must define and process the lanes in the
Fingerprint processing window.
1. In the Fingerprint files panel, double-click on the filename ec-XbaI-001 to open the Fingerprint window.
2. In the Fingerprint window, select File > Edit fingerprint data... (

) to open the Fingerprint processing

window.

3. In the next dialog box, select PFGE-XbaI and press <OK>.
The Fingerprint processing window opens. In this window we are going to process our TIFF file in 4 steps:
1. Strips (defining lanes)
2. Curves (extracting densitometric curves)
3. Normalization
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4. Bands (defining bands and quantification)
The steps are shown in the tabs in the bottom left corner of the window. The and buttons in the toolbar
are to move back and forth, respectively. The tabs can also be used for the navigation between the different
steps.

5.2

Step 1: Define strips

The imported gel image is surrounded by a green rectangle. Since BioNumerics recognizes the darkness as
the intensity of a band, make sure the bands appear as dark bands on a white background (see Figure 6).
In case the bands appear as white bands on a black background, invert the values: press
to
open the Fingerprint processing settings dialog box, check/uncheck the Inverted values check
box, and press <OK> to apply the changes.
The first step in processing a gel is to crop the image to remove empty space, and to define the lanes.
4. Delineate the area of the gel lanes by clicking and dragging the nodes of the rectangle to adjust it. Exclude
the wells from the rectangle (see Figure 6).

Figure 6: Area of gel lanes.

5. In the toolbar, press

to let the software search for the individual lanes.

6. Enter ”10” as the approximate number of lanes and press <OK>.
7. In the toolbar, press

to open the Fingerprint processing settings dialog box.

When opened in the Strips panel the Raw data tab is selected by default.
8. Adjust the Thickness of the image strips so the splines border the edges of the bands (e.g. 33 points).
9. Press <OK>.
10. Adjust the horizontal position of each spline as necessary by clicking and dragging a blue node. Hold
down the Shift-key while dragging a node to adjust the spline locally.
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11. Decrease the thickness of the spline in lane 10 by clicking one of its nodes and repeatedly pressing

or

F8. Then move the spline over to the good portion of the lane to the left (see Figure 7).

Figure 7: Adjusting the thickness and positions of the splines.

Next, we will edit the tone curve to improve the band visibility.
12. From the pull down menu, select Edit > Edit tone curve....
13. Press <Linear>.
The visible gray scale interval now ranges between the minimum and maximum values in the image (see
Figure 8).

Figure 8: The Gel tone curve window.

14. Press the other editing buttons such as <Enhance weak bands> a few times until you have a clear and
sharp image.

15. Press <OK> to save changes to the tone curve settings.
The gel tone curve does not change the image’s densitometric values, only the way they appear
in the Fingerprint processing window.
16. Press

to save the work already done.
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17. Press

5.3

to proceed to the Curves step or press the Curves tab.

Step 2: Define curves

Now that the lanes have been defined, the software can generate densitometric curves describing the optical
density across the spline along each lane. The left panel shows the strips extracted from the image file, the
right panel shows the densitometric curve of the selected pattern (see Figure 9). The area between the blue
lines of each lane will be used to calculate the densitometric curve.
18. Select lane 3.
Near the top of the lane in the spline there is a pinpoint spot. As a result, a thin peak appears on the
densitometric curve shown on the right side of the window.
19. It might help to zoom in on the image using the zoom slider.
20. Open the Fingerprint processing settings dialog box again (click on the

button).

21. Change the Averaging thickness for curve extraction to 15 in the Densitometric curves tab.
22. Check Median filter and press <OK>.
In lane 3, the thin peak - resulting from the pinpoint spot - has disappeared in the densitometric curve shown
on the right side of the window (see Figure 9).

Figure 9: Increased splines and median filtering.

BioNumerics can analyze the gel image to determine the optimal settings for removing background noise
from the densitometric curves.
23. Select Curves > Spectral analysis....
The following settings are shown in the Spectral analysis window:
1. Wiener cutoff scale: Determines the optimal setting for least square filtering.
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2. Background scale: Estimation of the disk size for background subtraction.
24. Close the Spectral analysis window.
25. Open the Fingerprint processing settings dialog box again (click on the

button).

26. Check Apply least square filtering and specify a Least square filtering Cut off as indicated by the
Wiener cutoff scale in the Spectral analysis window (use the percentage value, e.g. 1). Least square
filtering removes very small peaks from the curves.

27. Check Apply in the Background subtraction panel and specify a Background subtraction disk size as
indicated by the background scale in the Spectral analysis window (use the percentage value, e.g. 14).
Background subtraction removes large background trends from the curves.

Figure 10: The Fingerprint processing settings dialog box: the Densitometric curves tab.

28. Press <OK>.
The background noise has been removed from the curves (see Figure 11).

Figure 11: Curve after filtering.
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5.4

29. Press

to save the work already done.

30. Press

to proceed to the Normalization step or press the Normalization tab.

Step 3: Normalize the gel

Every fingerprint type experiment needs at least one reference system to normalize its gels. Since this is the
first Xba-I gel we have imported, we need to create a reference system based on the standard pattern in this
gel. We will use the standard’s molecular weights to name the reference positions. Subsequent Xba-I gels,
provided they contain the same standard, will be normalized with the same reference system.
31. Press

to enter the normalized view.

For now, the ”normalized view” looks the same as the original view. In a first step we will define the
reference lanes and the reference bands.
32. Select lane 1 and press

to assign it as a reference lane or select References > Use as reference lane.

33. Repeat this for lane 6 and lane 10.
34. Choose the most suitable standard lane for creating the reference system. For this exercise select lane 6
by clicking anywhere in the lane so that the lane number turns orange.

35. Right-click on the top band in lane 6 and select Add external reference position.
36. Enter 582.6 and press <OK>.
37. Repeat the process for each band in lane 6 as shown in Figure 12.
The reference system for experiment type PFGE-XbaI is now defined (see Figure 13).
38. Select Normalization > Auto assign... (

).

39. Make sure Using bands is selected and press <OK>.
40. Carefully inspect the assignments made (see Figure 13).
41. If a band assignment is incorrect, select the band and press the Del-key.
42. To assign a reference band manually, first click on the reference position tag, then hold the Ctrl-key and
click on the reference band to assign it to that reference position.

43. To update the normalization based on the band assignments, select Normalization > Update normalization ( , Ctrl+U).

44. Press

5.5

to proceed to the last step. Alternatively press the Bands tab.

Step 4: Define bands

If you want to use the curves to compare the patterns, no bands need to be assigned and this last step can be
skipped. If you want to compare the patterns using bands, you will need to assign bands in the sample lanes
in this last step. Usually, assigning bands in the sample lanes is done first with the software’s automatic band
search, followed by manual corrections. Some trial and error might be required to find the best settings for
the automatic band search.
45. To automatically search for bands, press

or select Bands > Auto search bands.
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Figure 12: Reference system.

Figure 13: Reference positions assigned.

In the Band search dialog box, the currently selected lane is shown along the bottom (see Figure 14).
46. To scroll through other lanes, press the < and > buttons on the left and right sides of the curve.
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Figure 14: The Band search dialog box.

47. Enter 5 for Min. Profiling, 2 for Gray zone, and press <Preview>.
The red lines across the lane at the bottom of the window indicate which peaks will be assigned bands with
the current settings. The purple area along the curve indicates the minimum profile above which a band is
assigned, while the blue area indicates the gray zone in which bands are considered ”uncertain”.
48. Press <Search on all lanes> to execute the band search with these settings.
Bands that are found are marked with a green horizontal line, whereas uncertain bands are marked with a
small green ellipse (see Figure 15). If you see any incorrect band assignments you can edit them manually:
• To add a band, hold down the Ctrl-key and click on the spot. The cursor automatically jumps to the
closest peak; to prevent this, hold down the Tab-key while clicking.
• To select a group of bands, hold down the Shift-key and click while dragging the mouse pointer
diagonally across the bands.
• To delete one or more selected bands, press the Del-key.
• To mark a band as uncertain, click on the band and select Bands > Mark band(s) as uncertain or
press F5. To mark a band as certain, click on the band and select Bands > Mark band(s) as certain
or press F6.
49. After you are satisfied with the band assignments, press

to save the file.

50. The program may prompt with the following question: ”The resolution of this gel differs considerably
from the normalized track resolution. Do you wish to update the normalized track resolution?” If the
question appears, answer <Yes>.

51. Exit the Fingerprint processing window by selecting File > Exit.
52. The software asks: ”Settings have been changed. Do you want to use the current settings as new defaults?” Select <Yes> so that the settings used for this gel will be saved in the fingerprint type settings.
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Figure 15: The Bands tab.

Congratulations! You have processed your first gel. The reference system and fingerprint settings that are
saved with the fingerprint type experiment will make future XbaI gels much faster to process.
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Linking fingerprint data to entries

Although we have created individual fingerprint lanes from our gel image, the software does not know which
lanes correspond to which entries in the database. Our next task is to link the fingerprint lanes to the entries
in our database.
1. In the Fingerprint files panel, double-click on the filename ec-XbaI-001 to open the Fingerprint window
(see Figure 16).

2. Select lane 2 and select Database > Link lane... or press

.

3. In the dialog box enter EC001 and press <OK>. Confirm the creation of the new entry.
You can also link a lane to an existing database entry by dragging the gray arrow icon to the entry key in the
database window. When a lane is linked, the icon becomes purple: .
4. Continue linking the remaining non-reference lanes from ec-XbaI-001 to new database entries as shown
in Figure 16.

You can also let the program create new entries and link the gel lanes automatically by selecting
Database > Add all lanes to database. All unlinked lanes will be added as new entries to the
database, with the gel lanes linked to these entries. The entries will be assigned a unique key.
5. After linkage, close the Fingerprint window and open the gel strip for one of the entries in the database
by clicking on a colored dot in the Experiment presence panel.
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Figure 16: Fingerprint file with linked lanes.

The card is displayed in raw mode (i.e. not normalized). The band sizes are shown as relative distances from
the top (see Figure 17).

Figure 17: Fingerprint type experiment card: raw mode.

6. Close the card by clicking in the small triangle-shaped button in the upper left corner.
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Fingerprint type experiment settings
1. Open the fingerprint experiment type PFGE-XbaI by double-clicking on the experiment type in the
Experiment types panel.

The Fingerprint type window shows the defined reference positions in relation to the distance on the pattern
in percentage. The reference system is called R01. The panel left from the reference system is still blank:
c 2018 Applied Maths NV. All rights reserved.
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the fingerprint still misses a standard pattern. We will link a Standard pattern (e.g. lane 6 of ec-XbaI-001,
i.e. the one used for defining the reference system) to the PFGE-XbaI fingerprint type as follows:
2. Close the Fingerprint type window.
3. In the Fingerprint files panel, double-click on ec-XbaI-001 to open the Fingerprint window.
4. In the Fingerprint window, add lane 6 to the database by selecting it and pressing

.

5. In the dialog box, enter ”REF” and press <OK>.
6. Select <Yes> to create the new entry in the database.
A new entry REF is created with the pattern from lane 6 of ec-XbaI-001 linked to it.
7. Close the Fingerprint window.
8. Open the fingerprint experiment type PFGE-XbaI by double-clicking on the experiment type in the
Experiment types panel.

9. Press

next to Standard in the Settings panel and drag it over to the REF database entry.

The standard pattern is now displayed in the panel next to the reference positions, and the database entry
key REF is indicated as the Standard (see Figure 18).

Figure 18: The Fingerprint type window.

If a standard pattern is assigned to a fingerprint type, this standard pattern is shown in the Normalization tab
of the Fingerprint processing window (see Figure 13) to make visual assignment of bands to the reference
positions easier. The choice of a standard has no influence on the normalization process since it is only used
as visual aid.
One more step is necessary before we can analyze our fingerprint patterns. Since there are gaps present
between the reference system positions, we must tell the software how to convert other band positions into
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metrics (e.g. molecular weights). We will use the reference system to construct a calibration curve which
translates all band positions into metrics.
10. In the Fingerprint type window, select Settings > Edit reference system or double-click on R01.
The Fingerprint Reference system window appears with the message: ”Could not calculate calibration curve.
Not enough markers.”
11. Since the molecular weights were already entered as names for the reference positions, we can copy these
molecular weights by selecting Metrics > Copy markers from reference system.... Confirm the action.

12. Designate a metric unit with Metrics > Assign units..., enter kb and press <OK> (see Figure 19).

Figure 19: Calibration curve calculated.

13. Close the Fingerprint Reference system window, and close the Fingerprint type window.
The fingerprint type PFGE-XbaI is now defined and configured, and one gel has been added to the database.
14. Open a gel strip for one of the entries in the database by clicking on a colored dot in the Experiment
presence panel.

The cards are now displayed in normalized mode (see Figure 20). Band sizes are shown as molecular sizes
based on the regression curve calculated in the previous step.

Figure 20: Fingerprint type experiment card: normalized mode.
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15. Increase or decrease the size of the card using the keyboard by pressing the numerical ”+” key (increase)
or the numerical ”-” key (decrease).

16. Close the card by clicking in the small triangle-shaped button in the upper left corner.
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Importing and processing a second gel file

A second gel file, ec-XbaI-002.tif, which was generated by PFGE with the restriction enzyme Xba-I is
present in the BioNumerics Tutorial data \PFGE TIFFS folder. For this second PFGE-XbaI gel, you
can use the same fingerprint type, reference system, and conversion settings used for the first gel.
Because the same reference system is present in the ec-XbaI-002 gel, you can skip the assignment of the
reference positions: in the third step you just have to assign the reference lanes (lane 1, 4, 7 and 10), execute
Normalization > Auto assign... ( ) and inspect the assignments made.
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Conclusion

In this tutorial you have seen how easy it is to import and process gel images in BioNumerics. You can now
start applying comparison functions such as band matching, clustering, etc. on the data. More information
about these functions can found in the analysis tutorials on our website.
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