BioNumerics Tutorial:

Import and quantification of a micro titer plate image
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Aims

BioNumerics can import character type data from TIFF images. This happens by quantification of the
color intensity and/or color transitions on the TIFF file. This character import tool is provided as a separate
program, BNIMA, that can be started from within BioNumerics. In this tutorial you will learn how to use
this import tool.
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Sample data

An example TIF image (Plate1.TIF) can be found on the download page on the Applied Maths website (http://www.applied-maths.com/download/sample-data, click on ”Microplate image”). It is a
photograph of a 96 wells micro titer plate with bromophenol blue as reaction indicator dye (see Figure 1).

Figure 1: 96 wells micro titer plate with bromophenol blue as reaction indicator.
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Creating a new character type

Since we will be importing character data, we first need to create a character type to hold this data. The
steps below can be skipped if a suitable character type is already present in the database.
1. Create a new database (see tutorial ”Creating a new database”) or open an existing database.
2. In the Main window, click on
from the list. Press <OK>.

in the toolbar of the Experiment types panel and select Character type
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The New character type wizard prompts you to enter a name for the new character type.
3. Enter a name, for example “Microplate” and press <Next>.
In the next step of the wizard, the choice is offered between Numerical values and Binary data.
4. Choose Numerical values.
5. Since we only want to use integer values, leave the number of decimal digits unaltered (zero).
After pressing <Next> again, the wizard asks if the character type has an open (Yes) or closed (No) character
set.
6. Answer No and set the Number of rows and Number of columns to zero.
7. Press the <Finish> button to complete the setup of the new character type.
The Experiment types panel now lists the new character type Microplate.
8. Double-click on Microplate in the Experiment types panel or highlight Microplate and select Edit >
Open highlighted object... (

, Enter).

The Character type window appears, initially with an empty character list.
A complete array of characters can be added quickly with Characters > Add array of characters....
9. Select Characters > Add array of characters... and specify “8” rows and “12” columns. Specify a
maximum value of “100” and press <OK> to add the 96 characters to the list.

The default color scale for all characters ranges from white (negative) to black (most positive). We will
specify a color scale from blue to yellow, over green for all characters:
10. Select Characters > Change character color scale....
The three slide bars represent red, green, and blue respectively.
11. Select the left-most point on the color scale. It is marked with a black triangle. Adjust the red, green and
blue components individually until you have obtained the blue color (see Figure 2).

Figure 2: Blue color.

12. Click on the right-most point on the color scale. It is now marked with a black triangle. Adjust the red,
green and blue components individually until you have obtained the yellow color (see Figure 3).

13. Select the <Add point> button. A new color mark appears in the middle. Adjust its color to green (see
Figure 4).

14. Press <OK> to apply the created color scale to all characters in the list (see Figure 5).
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Figure 3: Yellow color.

Figure 4: Green color.

The color scale is used in the Experiment card window and in comparisons. Each character listed in the
Character type window is by default marked with a green V-sign, which means that it is used in comparisons
and identifications. Characters marked with a red cross are disabled from comparisons and identifications.

Figure 5: The character type Micro plate.

15. Select Settings > General settings... (

) and click on the Experiment card tab of the dialog box.

16. Change the number of columns to “12”, set the Cell type to Large circular cup and press <OK>.
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17. Close the Character type window with File > Exit.
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Import and quantification
1. Add a new entry to the databasse: click on the Database entries panel to highlight this panel in the Main
window, select Edit > Create new object... (

) and press <OK>.

2. Double-click on the new entry in the Database entries panel to show its Entry window.
The experiment type Microplate shows an empty flask in the Experiments panel.
3. Click on the flask button. Since this experiment is not defined for this entry, the program asks ”Do you
want to create a new one?”.

4. Answer <Yes> to create an Experiment card window.
An empty micro plate image pops up.
5. Right-click on the empty card and select Edit image from the floating menu.
This loads the BNIMA program.
6. Select File > Load image (or press

) in BNIMA and load the file Plate1.TIF from the downloaded

and unzipped folder from the website.

The resulting window looks as in Figure 6.

Figure 6: The BNIMA program with a micro plate image loaded.

7. First call the Settings dialog box with Edit > Settings or

.
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The Image tab offers two choices for the Image type: Densitometric and Color scale.
In case the color reaction can be interpreted as a simple change in intensity (e.g. from light to dark), one
should select Densitometric.
In case the reaction causes a change from one color to another color, as in this example, Color scale is
the right option. An additional feature, Hue only, is particularly useful when the scanned images differ in
brightness (illumination) or contrast. If the images do not contain black or white in their color range, it is
better to enable this feature.

Figure 7: The Image tab.

8. Select Color scale and Hue only.
9. Press <OK> to proceed with these settings.
The processing of a character panel image exists of a number of steps: (1) Grid definition; (2) Cell layout;
and (3) Quantification.
In step 1 (Grid definition) we will create a grid that defines the wells of the micro plate.
10. Select Grid > Add new and enter ”8” as Number of rows and ”12” as Number of columns.
11. Press <OK>.
The grid appears. At each edge of the grid, there is a dragging node (green square). The upper left dragging
node is to move the grid as a whole; the lower right node is to resize the grid, and the upper right and lower
left nodes are to distort the grid in case the image is not perfectly rectangular or not scanned horizontally.
12. Drag the nodes until the grid matches with all 96 wells.
13. Move to the next step using Edit > Next step or the

button.

In this step, the layout of the cells is defined: the shape and size of the quantification area within each cell.
Before the program can do the quantification, it needs to know what the averaging area of the cells is. This
is done using a mask which the user defines. One can define the same mask for all cells, or assign particular
masks to individual (groups of) cells. In the case of a micro plate it is obvious that all cells should have the
same mask.
14. Click in the upper left corner of the image and, while holding the left mouse button down, select all cells
in the test panel.

All cells are marked in red.
15. Add a circular mask to all selected cells with Cells > Add disk to mask.
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Figure 8: Add disk to mask.

A dialog box prompts to enter a Radius for the disk in pixels, the X offset (horizontal shift from the cell
marking cross) and the Y offset (vertical shift from the cell marking cross). For the offsets, a negative value
can be entered.
16. Enter ”8” as radius, and leave the offsets zero. Press <OK> to confirm.
The masks appear on all used cells of the grid as semitransparent red disks.
Since we have specified Color scale as image type, we now need to specify the negative color, the positive
color, and any transition colors between negative and positive.
17. Make sure all cells are selected: click in the upper left corner of the image and, while holding the left
mouse button down, select all cells in the test panel.

18. Select Cells > Edit color scale or

.

This brings up the Color scale editor as shown in Figure 9.

Figure 9: Color scale editor in the Cell layout step of the BNIMA program.

By default, the color scale exists of two colors: white as negative and black as positive. In the case of
the example micro titer plate, this scale would obviously not work. Since the scale ranges from blueish
(negative) over greenish to yellow (positive), we will add a new intermediate color.
19. Press <Add color>. One new color (gray) is defined in the middle of the scale.
20. Select the color selector of the negative color (left).
21. Move the slider on the color scale of predefined colors to blue.
22. Move the slider in the Saturation/Brightness square to the lower left corner to obtain maximum brightness
and saturation.
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23. Repeat these steps for the intermediate color (middle), assigning green, and for the positive color (right),
assigning yellow.

The upper color scale now should range from blue over green to yellow.

Figure 10: Appropriate color scale for the example micro plate image.

With the Max. value field you can enter the maximum value to which all characters will be rescaled.
24. Enter 100 as Max. value and press <OK> to confirm the color settings.
25. Move to the next step using Edit > Next step or the

button.

The next and last step involves quantification of the cells. First of all, the cells to be added to the character
set need to be defined. In case one or more cells are intended only for calibration purposes, they can be
excluded from the resulting character set, but used as calibration marker.
26. Make sure all cells are selected: click in the upper left corner of the image and, while holding the left
mouse button down, select all cells in the test panel.

27. Select Quantification > Add cells to character set.
The cells are now numbered from 1 to 96.
28. If you click on a particular cell, its quantified value is given in the status bar as well as the value after
calibration (see further).

Quantification is done by integrating the pixels within the defined mask. There are different options for
integration:
29. Select Edit > Settings or

and choose the Quantification tab.

Figure 11: Quantification tab.

Cell integration methods include Average, Median, and Sum. In case the image contains spots that could
influence the quantified values, the median option will provide more reliable results than the arithmetic
averages.
30. Select Median integration and press <OK>.
In order to illustrate the calibration feature, we will define one of the cells as negative control (minimum
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value), and another cell as positive control (maximum value).
31. Select cell A1 (negative control) and Quantification > Define calibration point. Enter 0 as value and
press <OK>.

32. Select cell A12 (positive control) and Quantification > Define calibration point. Enter ”100” as value
and press <OK>.

Since only two calibration points are defined now, it is obvious that the program needs to calculate a linear
regression through the defined points, in order to re-quantify the other cells according to the negative and
positive controls:
33. Select Edit > Settings or

and choose the Quantification tab.

34. Under Calibration, enter 1 as Polynomial degree.
This will result in a first degree regression.
35. Press <OK> to close the Settings dialog box.
36. Select Quantification > View calibration curve.
This shows a linear regression between the two calibration points, zero and 100.
Finally, there is one more thing to do, i.e. to copy the character values in the micro plate opened in BioNumerics.
37. Select Quantification > Export to clipboard or

.

Before closing the BNIMA program, you can save the entire configuration defined for this micro plate
system. If you load a next micro plate, you can reload the grid and all other settings such as color scale,
disabled cells, quantification parameters etc.
38. Select File > Save configuration as or

.

39. Enter a name, e.g. ”micro plate”, and press <OK> to save the configuration.
For next micro plates you can reload the configuration using File > Load configuration or

.

40. Close the BNIMA program with File > Exit.
41. Right-click on the Experiment card window, and select Paste from clipboard from the floating menu.
The micro plate now is filled with data and looks like in Figure 12.

Figure 12: Example micro plate experiment card after import of character values using BNIMA.

42. Click the upper left triangular button to close the experiment card.
43. Confirm that you want to save the imported character values.
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