BioNumerics Tutorial:

Importing carbon source oxidation data from Omnilog csv files
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Aim

Sequential measurements that express an evolution of one parameter in function of another (e.g. enzymatic
activity, growth curves, etc.) are called trend type data and can be imported and analyzed in our BioNumerics
software package.
In this tutorial you will learn how to import trend data in your BioNumerics database, how to fit a curve
through the measurement points, and how to deduce parameters from the curve function to compare the
samples.
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Preparing the database

The DemoBase Connected will be used in this tutorial and can be downloaded directly from the BioNumerics Startup window or restored from the back-up file available on our website:
1. To download the database directly from the BioNumerics Startup window, click the Download example databases link, located in the lower right corner of the BioNumerics Startup window. Select
DemoBase Connected from the list and select Database > Download. Confirm the download action.
2. To restore the database from the back-up file, first download the file DemoBase Connected.bnbk
from http://www.applied-maths.com/download/sample-data, under ’DemoBase Connected’.
In the BioNumerics Startup window, press the
button, select Restore database, browse for the
downloaded file and select Create copy. Specify a name and click <OK>.
In contrast to other browsers, some versions of Internet Explorer rename the
DemoBase Connected.bnbk database backup file into DemoBase Connected.zip.
If
this happens, you should manually remove the .zip file extension and replace with .bnbk. A
warning will appear (”If you change a file name extension, the file might become unusable.”),
but you can safely confirm this action. Keep in mind that Windows might not display the .zip
file extension if the option ”Hide extensions for known file types” is checked in your Windows
folder options.
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Example data

The example Omnilog data files from which we will import data in this tutorial can be downloaded from the
Applied Maths website: go to http://www.applied-maths.com/download/sample-data and click on
’Trend data sample files’.
1. Open one of the files (e.g. G@Gel07@004.csv) to examine the data that will be imported.
Each file contains information about the utilization of carbon substrates of a certain strain (see Figure 1):
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Figure 1: Csv file: an example.

• The Hour column contains the X-values (= time points). Each panel is screened every 15 minutes.
• The 96 columns labeled with A01 to H12 contain the Y-values (= the data signal).
• The first row describes the columns.
• Additional columns are present containing plate and strain information.
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Create a trend data experiment
1. In the BioNumerics Startup window, double-click on the DemoBase Connected database to open it.
2. In the Main window, click on

in the toolbar of the Experiment types panel and select Trend data type

from the list (see Figure 2).

Figure 2: The Create a new experiment type dialog box.

3. Press <OK>, enter a name, for example Omnilog and press <Finish> to complete the creation of the
new trend data type.

The Experiment types panel now lists the trend data type Omnilog.
4. Open the Trend type window by double-clicking on Omnilog in the Experiment types panel.
The Trend type window is initially empty. Trend curves can be added either manually (TrendCurves > Add
new trend curve...) or during import (see 5).
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Importing trend data
1. Select File > Import... (

, Ctrl+I) to open the Import dialog box.

2. Choose the option Import trend data under the Trend data type data item in the tree and press <Import>.

Figure 3: Import tree.

3. Press <Browse> and browse for the downloaded csv files in the Omnilog folder.
The Input wizard page is updated (see Figure 4).

Figure 4: The Input wizard page.

4. Press <Next>.
As this is the first time we import trend data into the database, we need to create a new import template by
specifying Import rules.
c 2018 Applied Maths NV. All rights reserved.
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All columns detected in the selected csv files are listed in the grid.
5. Select the Strain Number row in the list and click <Edit destination> or simply double-click on the row.
Select ”Key” as the destination field and press <OK>.

6. Select the Hour row in the list and click <Edit destination>. Select ”X-axis” as the BioNumerics
destination field under Trend curve value > Omnilog in the Edit data destination dialog box and press
<OK> (see Figure 5).

Figure 5: The Edit data destination dialog box.

7. Click on ”A01”, scroll down the list and whilst holding the Shift-key, click on ”H12” to make a multiple
selection of the 96 trend data curves.

8. Press <Edit destination>, select ”Omnilog” under Trend curve value as destination and click <OK>
(see Figure 6).

Figure 6: The Edit data destination dialog box.

The software tries to map the column names to existing trend data curves. When there is no trend data curve
present with the same name, you will be prompted to create the new trend data curves (see Figure 7).
9. Press <OK> and then <Yes> to confirm the creation of the curves.
The grid is updated and should now look like in Figure 8.
10. Press the <Preview> button to verify that all information will correctly be imported in the database (see
Figure 9).
c 2018 Applied Maths NV. All rights reserved.
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Figure 7: Create new trend data curves.

Figure 8: Import rules.

11. Press <Next> to proceed to the Import links dialog box.
12. Make sure ”Key” is checked and press <Finish>.
The import template needs to be saved to be able to use it again later on.
13. Enter a Name for the import template (e.g. “Omnilog template”) and optionally a Description. Press
<OK>.

14. Highlight the newly created template and click <Next>.
This next dialog will indicate that 18 entries will be updated during import (see Figure 10).
15. Press <Finish> to start the actual import. The progress of the import is shown while database information is added to the BioNumerics database.

All entries for which data is imported are automatically selected in the Database entries panel.
c 2018 Applied Maths NV. All rights reserved.
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Figure 9: Preview of the parsed data.

Figure 10: Update entries in the database.

The imported trend data is stored in the trend data type Omnilog.
16. Double-click on the experiment Omnilog in the Experiment types panel.
The 96 trend data curves are displayed in the Curves panel of the Trend type window. Optionally a Description can be given to each curve:
17. Click twice on a cell in Description column. The information will appear highlighted and can be edited
(see Figure 11).

c 2018 Applied Maths NV. All rights reserved.
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Figure 11: The Trend type window.
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Defining parameters

For visualization and comparison purposes, a default curve fit model needs to be specified.
1. In the Trend type window select Settings > Default trend curve model... to call the Trend curve fit model
dialog box (see Figure 12).

Figure 12: Set trend curve model.

2. Choose a fit, e.g. Logistic growth and check both Use offset and Use generalized formula.
3. Press <OK> to set the curve model.
Before any analysis can be done, parameters have to be defined. Parameters can be deduced from the model
function (Parameters > Model parameters...) or from the original data points (Parameters > Statistics
parameters...).
4. In the Trend type window select Parameters > Statistics parameters... to call the Statistics parameters
dialog box.

5. Check Mean for the Y value and press <OK> (see Figure 13).
c 2018 Applied Maths NV. All rights reserved.
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Since all curves have been measured using the same time scale (= same X values), the mean intensity is a
relative measure for the Area Under the Curve (= AUC).

Figure 13: The Statistics parameters dialog box.

The Parameters panel now contains the selected parameter to be used for comparison (see Figure 15). Our
imported samples can now be compared based on the selected parameter rather than based on all original
data points.
6. Select Parameters > Parameter properties... to call the Parameter properties dialog box (see Figure 14).

Figure 14: Parameter properties.

7. Change the color scale of the selected parameter using the red, green and blue sliders.
8. Change the Maximum value to “300”, make sure Pearson correlation is selected as similarity Coefficient
and close the Parameter properties dialog box.

The color scale specified will be used when displaying the parameter values in the Comparison window (see
7).
9. Select Settings > General settings... (

) to call the Curve settings dialog box (see Figure 16).

10. Enter “Time” as X axis name and “Hours” as X axis unit. Press <OK>.
11. Close the Trend type window with File > Exit.
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Displaying trend data
1. Click on a colored dot in the Experiment presence panel of the Main window representing an Omnilog
trend data type for a particular entry.
c 2018 Applied Maths NV. All rights reserved.
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Figure 15: The Trend type window with one parameter defined.

Figure 16: General settings.

The curves for the selected entry are displayed in the experiment card (see Figure 17). Using the pull-down
list in the upper left corner of the card you can choose which curves to display.
2. Close the experiment card by clicking on the triangular button in the upper left corner.
Trend curves can also be displayed for multiple entries at a time in the same window. This is achieved as
follows:
3. Select a number of entries in the database for which trend curves are present using the Ctrl- and Shiftkeys.

Selected entries are marked by a checked ballot box ( ).
4. Double-click on the experiment Omnilog in the Experiment types panel to call the Trend type window.
5. Select File > Create trend data window (

) to open the Trend data window.

6. Select a trend curve from the drop down list in the toolbar.
The Curves panel displays the selected curve for all selected entries in a single plot (see Figure 18).
7. Close the Trend data window with File > Exit.
c 2018 Applied Maths NV. All rights reserved.
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Figure 17: Experiment presence card.

Figure 18: Trend curve displayed for multiple entries.

8. Make sure a few entries in the database are selected for which trend curves are present using the Ctrland Shift- keys.

9. Highlight the Comparisons panel in the Main window and select Edit > Create new object... (

) to

create a new comparison for the selected entries.
c 2018 Applied Maths NV. All rights reserved.
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10. Click on the

next to the experiment name Omnilog in the Experiments panel to display the defined
parameter(s) in the Experiment data panel (see Figure 19).

11. Select TrendData > Show parameter values colors to display the values of the parameter together with
the color as defined in the Trend type window (see 6).

Figure 19: The Comparison window.

12. Select a parameter in the Experiment data panel, and select TrendData > Sort entries by parameter
value (

).

The entries are sorted according to increasing value of the selected parameter.
13. A tab-delimited text file of the entries and trend data values contained in the comparison can be exported
with TrendData > Export character table.

14. Selecting TrendData > Create trend data window (

) calls the Trend data window again.

15. A cluster analysis (Clustering > Calculate > Cluster analysis (similarity matrix)...) on trend data can
be performed either by comparing the original data points of the curves, or by comparing the parameter
values.

16. To calculate correlation and regression on trend data, open the Trend analysis window with TrendData
> Perform trend analysis (

).
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