BioNumerics Tutorial:

Configuring the database layout
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Aim

The BioNumerics user interface is very flexible and can be customized to a high degree by the user, for
example by hiding information fields, panels and toolbars which are not needed in the context of an analysis,
or by only displaying database items based on user-defined settings using views (e.g. only displaying my
own experiment types, only displaying database entries that were added to the database in the last 30 days,
...). In this tutorial you will learn how to change the appearance of the information displayed in grid panels,
how to move, hide and enable panels and toolbars and how to use views.
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Preparing the database

The DemoBase Connected will be used in this tutorial and can be downloaded directly from the BioNumerics Startup window or restored from the back-up file available on our website:
1. To download the database directly from the BioNumerics Startup window, click the Download example databases link, located in the lower right corner of the BioNumerics Startup window. Select
DemoBase Connected from the list and select Database > Download. Confirm the download action.
2. To restore the database from the back-up file, first download the file DemoBase Connected.bnbk
from http://www.applied-maths.com/download/sample-data, under ’DemoBase Connected’.
In the BioNumerics Startup window, press the
button, select Restore database, browse for the
downloaded file and select Create copy. Specify a name and click <OK>.
In contrast to other browsers, some versions of Internet Explorer rename the
DemoBase Connected.bnbk database backup file into DemoBase Connected.zip.
If
this happens, you should manually remove the .zip file extension and replace with .bnbk. A
warning will appear (”If you change a file name extension, the file might become unusable.”),
but you can safely confirm this action. Keep in mind that Windows might not display the .zip
file extension if the option ”Hide extensions for known file types” is checked in your Windows
folder options.
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3.1

Display options in grid panels
Grid panels
1. In the BioNumerics Startup window, double-click on the DemoBase Connected database to open it.

In a BioNumerics database, all major data classes can be seen as database items. Examples of such items
are database entries, fingerprint files, comparisons, etc... Lists of BioNumerics database items are displayed
in grid panels. Each grid panel consists of information fields organized in columns and database items of a
certain type in rows.
2. Click somewhere in the Experiment types panel to make it the active panel.
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One of the rows in the Experiment types panel is highlighted in orange, indicating the active state of the
panel (see Figure 1).

Figure 1: The Main window with the active Experiment types panel.

3. Select Edit in the menu of Main window.
All commands listed under the Edit menu apply to the active panel, which is the Experiment types panel in
this example (see Figure 2).

Figure 2: Edit commands applicable to the Experiment types panel.

3.2

Column display options
4. Click somewhere in the Fingerprint files panel to make it the active panel.
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5. Move the separator line in the column heading left or right to change the width of a column.
6. Select Edit > Information fields > Add information field... or right-click in the information fields
header of the Fingerprint files panel and select Add information field.

7. Specify a name (e.g. Restriction enzyme) and press <OK> to add the new column to the Fingerprint
files panel.

Column properties can be accessed via the column properties button
information fields header (see Figure 3 for an example).

, located on the right hand side in the

Figure 3: Column properties of the Fingerprint files panel.

8. Click on the column properties button

in the header of the Fingerprint files panel and select Set active

fields (see Figure 3).

This pops up the Set active fields dialog box as shown in Figure 4. The Set active fields dialog box lists
all information fields defined for the Fingerprint files panel in the database. The fields for display can be
enabled and disabled with the check boxes next to the field names.

Figure 4: The Set active fields dialog box: checked fields will be displayed in the corresponding grid panel.

9. Check the field Creation date (if not already checked) and press <OK> to update the display of the
fields.

The relative position of a selected column within a panel can be changed as follows:
10. Click on a column in the Fingerprint files panel, click on the column properties button

and use the
menu items Move ’column name’ to left and Move ’column name’ to right to change the position of the
selected column. Alternatively use the shortcut keys Ctrl+left arrow and Ctrl+right arrow.
c 2018 Applied Maths NV. All rights reserved.

4
11. To revert to the default column properties settings for the active panel, click on the column properties
button

and select Restore default settings.

This action will disable all introduced changes to the column properties of the grid panel.
12. Click somewhere in the Database entries panel to make it the active panel.
13. Click on the column properties button

in the header of the Database entries panel and select Set active

fields.

The dialog that pops up lists all default entry fields. The fields for display can be enabled and disabled with
the check boxes next to the field names (see Figure 5).

Figure 5: Default entry fields.

14. Close the dialog and click on the Entry fields tab located in the upper right corner of the Main window to
make it the active panel.

All non-default entry fields defined in the database are displayed in the Entry fields panel (see Figure 7).

Figure 6: Non-default entry fields.

15. Select the Genus and Species fields.
To select an item in the list, simply click on the check box with the mouse, or Ctrl+click the item. To select
a range of items, click on the first item in the list and – whilst holding the Shift-key on the keyboard –
clicking on the last item to be selected.
16. Click on <All Entry fields> in the toolbar of the Entry fields panel and select <Selected Entry fields>
from the drop-down list.

The Database entries panel is updated.
17. To show all entry fields again in the Database entries panel, click on the drop-down list in the toolbar of
the Entry fields panel and select <All Entry fields>.
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3. Display options in grid panels

3.3

5

Row display options
18. Click on the Type column header in the Experiment types panel to make it the active column.

The rows in the grid can be sorted based on the content of the highlighted column in several ways:
• Edit > Information fields > Sort by field arranges information alphabetically (a to z).
• Edit > Information fields > Sort by field (reverse) sorts information in reverse alphabetical order
(z to a).
• Edit > Information fields > Sort by field (Numerical) sorts numerical information in ascending
order.
• Edit > Information fields > Sort by field (Numerical, reverse) sorts numerical information in
descending order.
19. Select Edit > Information fields > Sort by field or right-click on the column name Type and select Sort
by field to arrange the information alphabetically.

20. A selected row can be moved up or down the list using the Edit > Move up (
(

) and Edit > Move down

) options.

All information available in the database is standard displayed in each grid panel: the view in the toolbar of
each panel is default set to <All ...> (see Figure 7 for an example). One can easily switch to another view
via the drop-down list.

Figure 7: The Experiment types panel: all experiment types are default displayed.

21. Click on the drop-down list in the toolbar of the Experiment types panel (see Figure 8).

Figure 8: An example of a view drop-down list, here from the Experiment types panel.

Four predefined views are available in each grid panel: <Loaded ...> (all database items loaded into memory), <All ...> (all database items available in the database), <My ...> (all database items of which the
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logged-in user is the owner), <Selected ...> (all currently selected database items). To illustrate these
options, we will first create a selection in the Experiment types panel.
22. Select the two RFLP fingerprint type experiments in the Experiment types panel (see Figure 9).
To select an item in the list, simply click on the check box with the mouse, or Ctrl+click the item. To select
a range of items, click on the first item in the list and – whilst holding the Shift-key on the keyboard –
clicking on the last item to be selected.

Figure 9: Two selected experiments.

23. Click on the drop-down list in the toolbar of the Experiment types panel and choose the <Selected Experiment types> option (see Figure 8).

The experiment list in the Experiment types panel and Experiment presence panel is updated.
24. Switch back to the previous view by clicking on the drop-down list in the toolbar of the Experiment types
panel and choose the <All Experiment types> option.

Besides the four predefined views, it is also possible to create and save your own custom views based on a
selection or based on query.
25. Make sure the two RFLP experiments are still selected in the Experiment types panel, click on the dropdown list in the toolbar of the Experiment types panel and choose <Manage user defined views...> to
call the Manage user views dialog box.

26. Click the <Add> button to call the New object view dialog box (see Figure 10).

Figure 10: A selection based view.

27. Specify a name (e.g. Two RFLP experiments), make sure the Subset based option is selected and press
<OK> and <Exit>.
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The new view is added to the drop-down list in the Experiment types panel and is automatically selected
(see Figure 11).

Figure 11: A new selection-based view added to the list.

A selection based view is a static view: when new items are added to the database they will never automatically be part of the view, unless they are explicitly assigned to the view after creation (this can be done with
the <Edit> button in the Manage user views dialog box).
A query based view is a dynamical view: when new database items are added to the database that fulfill the
criteria present in the query, they will be returned by the view. As an example we will create a query based
view that will return all Perdrix entries in the Database entries panel.
28. Click on the drop-down list in the toolbar of the Database entries panel and choose <Manage user
defined views...> to call the Manage user views dialog box.

29. Click the <Add> button to call the New object view dialog box (see Figure 12).

Figure 12: A query based view.

30. Specify a name (e.g. Perdrix entries), make sure the Query based option is selected and press <OK>.
31. Type Perdrix next to Genus and select Equals from the list (see Figure 13).
32. Press <OK>, <Yes> and <Exit>.
The new view is added to the drop-down list in the Database entries panel and is automatically selected (see
Figure 14). When new entries are added to the database having the text Perdrix in the Genus field, they will
automatically be included in the view.
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Figure 13: Query criterion.

Figure 14: A new query-based view added to the list.

As a second example we will create a query based view that will return all entries in the Database entries
panel that were added to the database in the last 30 days.
33. Click on the drop-down list in the toolbar of the Database entries panel and choose <Manage user
defined views...> to call the Manage user views dialog box again.

34. Click the <Add> button to call the New object view dialog box.
35. Specify a name (e.g. Added last 30 days), make sure the Query based option is selected and press <OK>
(see Figure 15).

Figure 15: A query based view.
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36. Select <Add new> to add a new item to the list.
37. Click on the ? item and select Creation date. Select [CurrentDate]-14 from the list next to Creation
date, and change -14 to -30. Select Larger than from the list (see Figure 16) and press <OK>, <Yes>
and <Exit>.

Figure 16: Query criterion.

The new view is added to the drop-down list in the Database entries panel and is automatically selected.
All entries added to the database in the last 30 days are automatically included in the view.
38. To add a new entry to the database, click on the Database entries panel to highlight this panel in the Main
window, select Edit > Create new object... (

) and press <OK>.

The new entry is added to the database and is automatically added to the Added last 30 days view.
39. Click on the drop-down list in the toolbar of the Database entries panel and choose <All Entries> to
display all entries again.

40. Click on the drop-down list in the toolbar of the Fingerprint files panel and choose <Manage user defined
views...> to call the Manage user views dialog box (see Figure 17).

The option Load complete set at start of a session in the Manage user views dialog box can be very useful
in case of large databases. When this option is unchecked, only those database items (here: fingerprint
files) that are retrieved by the selected Startup view are loaded in computer memory. When the <Loaded
Fingerprint files> view is selected as Startup view, no fingerprint files will be loaded when opening the
database. This will significantly reduce the startup time of databases having a lot of fingerprint files.
41. Select the <Loaded Fingerprint files> view as Startup view in the Manage user views dialog box and
uncheck Load complete set at start of session. Press <Exit>.

42. Close and reopen the database.
The <Loaded Fingerprint files> view is now the default view in the Fingerprint files panel. If you want to
see a fingerprint file associated with an entry, it will be dynamically fetched when clicking on a green dot in
the Experiment presence panel. Alternatively, open the Entry window (double-click on the entry), and click
on the link (purple arrow).
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Moving grid panels

The Main window in default configuration consists of a menu, a toolbar for quick access to the most important functions, a status bar, and several panels. If for example you are only interested in the analysis of
sequences the Fingerprint files panel is not needed at all in this context and can therefore be removed from
the display:
1. Right-click on the header of the Fingerprint files panel and select Close Fingerprint files.
The Fingerprint files panel is now hidden. If the panel needs to be displayed again, proceed as follows:
2. Select Window > Show / hide panels in the Main window.
This displays a sub-menu, listing all available panels. Panel names for which a check mark is present left of
the menu item are shown in the window.
3. Click on Fingerprint files in the sub-menu. The Fingerprint files panel is now displayed again.
c 2018 Applied Maths NV. All rights reserved.
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Figure 17: Load fingerprint file information dynamically.

Furthermore, dockable panels can be placed on the screen in one of two modes: floating or docked. Floating
allows the window to be placed anywhere on the screen, the docked mode automatically places the panel in
one of five locations: top, bottom, left, right, or stacked onto another panel (tabbed view). The position of a
panel is controlled with a docking guide (see Figure 18).

Figure 18: Docking the Fingerprint files panel as a tabbed view.

4. Click in the header of the Fingerprint files panel and - while keeping the mouse button pressed - drag it
towards the Experiment types panel. As soon as the panel leaves its original position, a docking guide
appears in the center of the Experiment types panel. Release the mouse button on any place next to the
docking guide to leave the panel floating in the window.

A floating window can be repositioned to any place on your monitor.
5. Click in the Fingerprint files panel header and drag it towards the Experiment types panel again. Drop
the Fingerprint files panel on the center of the docking guide (see Figure 18).

As a result, the Fingerprint files panel is now displayed as a tabbed view with the Experiment types panel
c 2018 Applied Maths NV. All rights reserved.
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and Entry fields panel (see Figure 19).

Figure 19: Result of the action depicted in Figure 18: tabbed view of the Experiment types
panel, Entry fields panel and Fingerprint files panel.

The position of a toolbar within a window or panel can be altered as follows:
6. In the header of the Main window, click on the dark gray area in a toolbar, left of a set of buttons. The
mouse pointer will take the shape of a hand on top of two arrows. Drag the toolbar left or right to change
the order in which the toolbars appear.

7. In the header of the Main window, drag another toolbar slightly downwards to make the toolbars appear
in two rows.

8. Click on a toolbar again and drag it to the left (or right or bottom) part of the window to dock it on the
left (or right or bottom) part of the window.

After making some changes to the window configuration (panels as well as toolbars), it is always possible
to return to the default configuration for the active window. If you intend to revert to the user-defined
configuration afterwards, then you can save the user-defined configuration first and recall it afterwards.
9. Select Window > Save current configuration to store the configuration that you have just defined.
10. To restore the default configuration, select Window > Restore default configuration. The window now
appears back in its original configuration.

11. Recall the user-defined configuration with Window > Recall saved configuration. Notice that the
changes you made to the window configuration are introduced again.

12. Any window configuration can be protected from accidental changes via Window > Lock configuration.
13. Configuration changes will be enabled if Window > Lock configuration is selected again.
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Conclusion

Customizing the database layout of your BioNumerics database as described in the sections above will help
you in accessing your data and analyses in BioNumerics in the most efficient way.
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